☭当前位置:逗文摘 > 随摘 > 浏览文摘

勇整理的益盟操盘手指标V1

2021年03月15日 阅读量:

作者整理的自用益盟操盘手指标:

Y1-天下第二指标:主图叠加

参数:

P1 (0, 100, 5, 1);

P2 (0, 100, 20, 1);

P3 (0, 100, 60, 1);

代码:

DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG),LINETHICK2;

DEA:EMA(DIF,M);

MACD:2*(DIF-DEA),LINETHICK0;

STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,1,1),COLORRED;

STICKLINE(MACD>=0 AND MACD< REF(MACD,1),0,MACD,1,1),COLORYELLOW;

STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,1,1),COLORE541F1;

STICKLINE(MACD<0 AND MACD< REF(MACD,1),0,MACD,1,1),COLORGREEN;

M1=REF(MACD,3)>REF(MACD,2) AND REF(MACD,2)>REF(MACD,1) AND MACD>REF(MACD,1);

M2=BARSLAST(REF(M1,1));

MACD底背:=MACD>REF(MACD,M2+1) AND M1;

DRAWTEXT(MACD底背,MACD*1.2,'M'),COLORYELLOW;

D1=REF(DIF,3)>REF(DIF,2) AND REF(DIF,2)>REF(DIF,1) AND DIF>REF(DIF,1);

D2=BARSLAST(REF(D1,1));

DIF底背:=DIF>REF(DIF,D2+1) AND D1;

DRAWTEXT(DIF底背,DIF*1.2,'D'),COLORYELLOW;

M背:MACD底背,LINETHICK0;

D背:DIF底背,LINETHICK0;

Y2-MACD优化指标

参数:

SHORT (1, 40, 10, 1); 

LONG (2, 100, 21, 1); 

M (1, 60, 9, 1); 

代码:

DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG),LINETHICK2;

DEA:EMA(DIF,M);

MACD:2*(DIF-DEA),LINETHICK0;

M1 = REF(MACD,3)>REF(MACD,2) AND REF(MACD,2)>REF(MACD,1) AND REF(MACD,1) < MACD;

M2 = BARSLAST(REF(M1,1));

MACD底背:=MACD>REF(MACD,M2+1) AND M1 AND C>O AND C/REF(C,M2+1) <= 1.05;

DRAWTEXT(MACD底背,MACD*1.2,'M'),COLORYELLOW;

M3 = REF(MACD,3)>REF(MACD,2) AND REF(MACD,2)>REF(MACD,1) AND REF(MACD,1) < MACD AND MACD>0;

DRAWTEXT(M3,HHVALL(MACD),'升'),COLORYELLOW;

D1:=BARSLAST(REF(CROSS(DIF,DEA),1));

D2:=REF(C,D1+1)>C AND REF(DIF,D1+1)<DIF AND CROSS(DIF,DEA);

DRAWTEXT(FILTER(D2>0,5),dif*1.2,'D'),COLORYELLOW;

操盘:STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,1,1),COLORRED;

减仓:STICKLINE(MACD>=0 AND MACD< REF(MACD,1),0,MACD,1,1),COLORYELLOW;

反弹:STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,1,1),COLORE541F1;

寻底:STICKLINE(MACD<0 AND MACD< REF(MACD,1),0,MACD,1,1),COLORGREEN;

M背:MACD底背,LINETHICK0;

D背:FILTER(D2>0,5),LINETHICK0;

升:M3,LINETHICK0

Y3-私募洗盘代码

{吸筹}

VAR1:=IF(YEAR>=2993 AND MONTH>=1,0,1);

VAR2:=REF(LOW,1)*VAR1;

VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100*VAR1;

VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3)*VAR1;

VAR5:=LLV(LOW,30)*VAR1;

VAR6:=HHV(VAR4,30)*VAR1;

VAR7:=IF(MA(CLOSE,58),1,0)*VAR1;

VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*VAR1;

VAR9:=IF(VAR8>100,100,VAR8)*VAR1;

STICKLINE(VAR9>-150,0,VAR9,6,1),COLORMAGENTA;

{私募}

A1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);

A2:=SMA(ABS(LOW-A1),13,1)/SMA(MAX(LOW-A1,0),10,1);

A3:=EMA(A2,10);

A4:=LLV(LOW,33);

A5:=EMA(IF(LOW<=A4,A3,0),3);

私募进场:IF(A5>REF(A5,1),A5,0),COLORRED;

私募洗盘:IF(A5<REF(A5,1),A5,0),COLORGREEN;

{黄金线}

重心:=(C+0.618*REF(C,1)+0.382*REF(C,2)+0.236*REF(C,3)+0.146*REF(C,4))/2.382;

RSI:=SMA(MAX(重心-REF(重心,1),0),5,1)/SMA(ABS(重心-REF(重心,1)),5,1);

黄金线买:CROSS(RSI,0.1)*20,COLORYELLOW;

黄金线卖:CROSS(0.9,RSI)*10,COLORE541F1;

Y4-筹码峰代码

HL:=(COST(99.99)-COST(0.01))/15;

CM1:=WINNER(HL*1)-WINNER(HL*0);

CM2:=WINNER(HL*2)-WINNER(HL*1);

CM3:=WINNER(HL*3)-WINNER(HL*2);

CM4:=WINNER(HL*4)-WINNER(HL*3);

CM5:=WINNER(HL*5)-WINNER(HL*4);

CM6:=WINNER(HL*6)-WINNER(HL*5);

CM7:=WINNER(HL*7)-WINNER(HL*6);

CM8:=WINNER(HL*8)-WINNER(HL*7);

CM9:=WINNER(HL*9)-WINNER(HL*8);

CM10:=WINNER(HL*10)-WINNER(HL*9);

CM11:=WINNER(HL*11)-WINNER(HL*10);

CM12:=WINNER(HL*12)-WINNER(HL*11);

CM13:=WINNER(HL*13)-WINNER(HL*12);

CM14:=WINNER(HL*14)-WINNER(HL*13);

CM15:=WINNER(HL*15)-WINNER(HL*14);

MXCM:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(CM1,CM2),CM3),CM4),CM5),CM6),CM7),CM8),CM9),CM10),CM11),CM12),CM13),CM14),CM15);

峰价上:=C+

IF(CM15=MXCM,HL*15,IF(CM14=MXCM,HL*14,IF(CM13=MXCM,HL*13,IF(CM12=MXCM,HL*12,IF(CM11=MXCM,HL*11,IF(CM10=MXCM,HL*10,IF(CM9=MXCM,HL*9,IF(CM8=MXCM,HL*8,IF(CM7=MXCM,HL*7,IF(CM6=MXCM,HL*6,IF(CM5=MXCM,HL*5,IF(CM4=MXCM,HL*4,IF(CM3=MXCM,HL*3,IF(CM2=MXCM,HL*2,IF(CM1=MXCM,HL*1,0))))))))))))))),COLORGREEN;

峰价下:=峰价上-HL,COLORWHITE;

峰价中:峰价上-HL*0.5,COLORMAGENTA;

峰量:MXCM*100;

XG:C>=峰价中 AND O<峰价中 AND C>O;

相关阅读
杨凯老师非二选股步骤实用MACD买入卖出方法自用 益盟操盘手MACD优化指标杨老师反弹步骤策略

随摘排行榜
自用 操盘手天下第二主图指标自用 益盟操盘手MACD优化指标实用MACD买入卖出方法HTML5中用respond.js解决响应式布局问题杨老师反弹步骤策略WIN7下打印机删除不了怎么办Photoshop启动提示:$$$/ADMDialog/ifontproblemWarning=解决办法杨凯老师非二选股步骤自用 操盘手筹码峰突破选股指标庄家吸筹过程的三种走势图

本站逗文摘纯属个人爱好摘录,如转载的内容无意侵犯了您的版权,请联系QQ3403003689,谢谢!